Failed to parse Nordic PPK configuration data


#1

I am using the Nordic Power Profiling Kit (PPK) for measuring power consumption. Reading the Nordic forum, I happened to see a post talking about otii. I have now flashed the PPK with firmware 1.1.0 as I am not sure if otii supports the newest firmware that is automatically flashed using the Nordic nRF Connect app.

But now when I start otii I get the following error message:
“Failed to parse Nordic PPK configuration data”

What can I do now?


#2

Hello

Could you please attach otii.log found in the otii folder in your documents folder and we’ll see if it has any clues.

Also, what OS are you using?


#3

I had a closer look at this issue. I could after upgrading to latest, successfully downgrade to 1.1.0 firmware again and use that together with Otii.

I also had a look at the new configuration data. Even if I adapt Otii to the new format something else in the protocol has changed. Earlier we could follow the changes in the Nordic python application and adapt accordingly. But, as you probably know, they don’t release that any more.


#4

@chrfle How did you manage to downgrade it?

I’ve tried flahsing the PPK through nRF Connect and then using it with Otii but I get the same error mentioned above. If you can still get it to work, could you send some instructions on how to do it?


#5

If I recall correctly, when you connect the PPK it shows up as a mass storage unit. You can drag and drop the ppk_110.hex to that unit and it will flash and restart.


#6

Yes, that seems to get me past that issue. I downloaded the old FW zip from this page and copied the hex to the mass storage unit. https://www.nordicsemi.com/eng/Products/Power-Profiler-Kit
However I didn’t realize I need Otii premium so I can’t test it out.


#7

I added you a license valid till Sunday so go ahead and test it.


#8

Thank you, with the license it worked really well. More stable and powerful than Nordics own power profiler software.