Ubuntu 22.04 Installation problem

Hi,
I tried to use latest Otii SW on Ubuntu 22.04
Mainly I struggled to do the login procedure…found the forum post regarding fixing libssl to get it working.

It gives an error during installation already stating it depends on libssl1.1
I can install libssl3 only.

otii : Depends: libssl1.1 (>= 1.1) but it is not installable

E: Unmet dependencies. Try ‘apt --fix-broken install’ with no packages (or specify a solution).

If I try to fix broken install, it will remove the whole package:
sudo apt --fix-broken install

The following packages will be REMOVED:
otii

Full log below.
Thx,
Markus

Linux HarveySpectre 5.15.0-40-generic #43-Ubuntu SMP Wed Jun 15 12:54:21 UTC 2022 x86_64 x86_64 x86_64 GNU/Linux

me@HarveySpectre:~/Downloads$ sudo dpkg -i otii_2.8.4.deb
Selecting previously unselected package otii.
(Reading database … 232777 files and directories currently installed.)
Preparing to unpack otii_2.8.4.deb …
Unpacking otii (2.8.4) …
dpkg: dependency problems prevent configuration of otii:
otii depends on libssl1.1 (>= 1.1); however:
Package libssl1.1 is not installed.

dpkg: error processing package otii (–install):
dependency problems - leaving unconfigured
Processing triggers for mailcap (3.70+nmu1ubuntu1) …
Processing triggers for gnome-menus (3.36.0-1ubuntu3) …
Processing triggers for desktop-file-utils (0.26-1ubuntu3) …
Processing triggers for hicolor-icon-theme (0.17-2) …
Processing triggers for shared-mime-info (2.1-2) …
Errors were encountered while processing:
otii

me@HarveySpectre:~$ sudo apt install libssl-dev
Reading package lists… Done
Building dependency tree… Done
Reading state information… Done
Suggested packages:
libssl-doc
The following NEW packages will be installed:
libssl-dev
0 upgraded, 1 newly installed, 0 to remove and 5 not upgraded.
Need to get 2.371 kB of archives.
After this operation, 12,4 MB of additional disk space will be used.
Get:1 Index of /ubuntu jammy-updates/main amd64 libssl-dev amd64 3.0.2-0ubuntu1.5 [2.371 kB]
Fetched 2.371 kB in 0s (9.205 kB/s)
Selecting previously unselected package libssl-dev:amd64.
(Reading database … 232629 files and directories currently installed.)
Preparing to unpack …/libssl-dev_3.0.2-0ubuntu1.5_amd64.deb …
Unpacking libssl-dev:amd64 (3.0.2-0ubuntu1.5) …
Setting up libssl-dev:amd64 (3.0.2-0ubuntu1.5) …

me@HarveySpectre:~ sudo apt install libssl3 Reading package lists... Done Building dependency tree... Done Reading state information... Done libssl3 is already the newest version (3.0.2-0ubuntu1.5). libssl3 set to manually installed. You might want to run 'apt --fix-broken install' to correct these. The following packages have unmet dependencies: otii : Depends: libssl1.1 (>= 1.1) but it is not installable E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution). markus@HarveySpectre:~ sudo apt --fix-broken install
Reading package lists… Done
Building dependency tree… Done
Reading state information… Done
Correcting dependencies… Done
The following packages will be REMOVED:
otii
0 upgraded, 0 newly installed, 1 to remove and 5 not upgraded.
1 not fully installed or removed.
After this operation, 98,9 MB disk space will be freed.
Do you want to continue? [Y/n] y
(Reading database … 233808 files and directories currently installed.)
Removing otii (2.8.4) …
Processing triggers for hicolor-icon-theme (0.17-2) …
Processing triggers for gnome-menus (3.36.0-1ubuntu3) …
Processing triggers for shared-mime-info (2.1-2) …
Processing triggers for mailcap (3.70+nmu1ubuntu1) …
Processing triggers for desktop-file-utils (0.26-1ubuntu3) …

Hi,

Our software is dependent on a 3rd-party component that requires openssl 1.1. Until this is fixed by the vendor we recommend our customers to stay with Ubuntu 21.10 or an earlier release.

There is however a hack that has worked out for some of our customers. You need to manually install openssl 1.1 before installing Otii:

# wget http://archive.ubuntu.com/ubuntu/pool/main/o/openssl/libssl1.1_1.1.0g-2ubuntu4_amd64.deb
# sudo dpkg -i libssl1.1_1.1.0g-2ubuntu4_amd64.deb
# sudo dpkg -i otii_2.8.4.deb

Best Regards,
Joakim

1 Like

Thanks joakim,
that worked for me.
Good not to have otii removed automatically after every Ubuntu SW update :slight_smile: