Unmet dependencies on Ubuntu 18.04

With Otii 2.4.0 installed from the deb, I get a warning that it has unmet dependencies when running apt again, meaning that it’s not possible to install other software without uninstalling Otii first.

Although the Otii software appears to function (I don’t have a premium package to check extended functionality), it did fail to install silently when using the Software Center to install the deb, and only actually installed by using dpkg on the command line.

OS: Ubuntu 18.04
Otii version: 2.4.0
Steps to reproduce: Install with sudo dpkg -i otii_2.4.0.deb
Expected result: dpkg should be able to meet all the dependencies of otii during install
Actual result: otii installs an appear to work with all the expected features (no licence key used), but the unmet dependencies mean otii has to be removed before any other software can be installed or updated.

Following install of Otii:

~ % sudo apt install <any_package>
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies.
 otii : Depends: libssl-dev (< 1.1.0) but it is not going to be installed or
                 libssl1.0-dev but it is not going to be installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

Following apt’s suggestion to --fix-broken:

~ % sudo apt -f install                             
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following packages will be REMOVED
0 to upgrade, 0 to newly install, 1 to remove and 0 not to upgrade.
1 not fully installed or removed.
After this operation, 112 MB disk space will be freed.
Do you want to continue? [Y/n]

The current version of libssl-dev is 1.1.0g-2ubuntu4.3, there is a version <1.1.0 in libssl1.0-dev 1.0.2n-1ubuntu5.

What’s the best way to go about solving this problem?

If you are not developing anything related to ssl (don’t care what version your libssl-dev package is) I would suggest gdebi otii_2.4.0.deb. If you don’t have gdebi then install it from your usual apt sources. gdebi will resolve the dependencies.

If you are doing ssl related work you need a future version of Otii built with a newer version of the Qt framework. If you are interested in trying this you can create a case and I will attach a software for you. Please be advised though that it has not passed quality assurance so there might be unexpected bugs related to the Qt upgrade.

1 Like

OK, that’s great, thanks.

sudo apt install gdebi
sudo gdebi install otii_2.4.0.deb

sorted that right out for me.