Unable to send AT-commands


#1

I want to measure the energy of a modem on a board called EE-NBIOT-01 v1.1. I have verified that I am able to communicate with the modem on baud rate 9600 (using a TTL to USB cable and CoolTerm for serial communication). Now I want to send AT-commands with the OTII while measuring.

Physical setup:
computer-to-OTII by supplied usb to micro-usb cable.
OTII to EE-NBIOT-01 for power by banana cables from + and - with HM6410 clamps to male-to-female jumper cables (sc13051 cables) to GND and VCC (EDIT: this has later been changed to 3.3V instead of VCC).
OTII to EE-NBIOT-01 for communication via jumper cables, TX on OTII to TXD on EE, RX on OTII to RXD on EE, DGND on OTII to GND on EE.
See image:
setup_Otii_ee

OTII setup:
new project created with LOGS - enable UART baudrate 9600. 3.3V.

Problem:
The board is powered and modem working, however no text commands are sent when attempting to send using the UART (when entering a command into “Text to send…” and typing enter, the text is simply highlighted. As you can see on the image below, the UART log shows RX log from the modem.
see image:
image


How can I verify that Otii sends commands?
#2

We have been able to hook up the EE-NBIOT-01 to an Otii Arc and send/receive AT-commands. I don’t think you need to connect DGND when powering it from the Otii, but I don’t know the Otii that well. If I’m not mistaken - the command is sent even though the UI does not reflect that. Would be nice if they could include TX data in the UART log. Did you also set the «Digital voltage level» to 3.3V? The «Digital voltage level» also affect the TX-/RX-pin.

By the way, it looks like you’ve been able to receive a message from the EE-NBIOT-01: +UFOTAS: 0,1. It usually appears a few seconds after booting, and the 0 means no firmware over the air available. If you click the button on the EE-NBIOT-01 it will reset the modem, and you should see some messages in the UART log (if it’s set up correctly). The last line should be OK. You can also try just sending AT when testing, and it should reply OK back if the serial is working.

The screenshot is quite low resolution, so hard to be sure, but from what I can see you’ve connected it correctly. For other readers; it is correct to connect TX to TX and RX to RX. That’s how U-blox do it. Looks like you’ve connected + on the Otii to VCC on the EE-NBIOT-01 (a natural thing to do). However, the voltage regulator on the EE-NBIOT-01 is not optimal for low power. If you want to do low power prototypes/measurements you should check out our guide on low power.


#3

DGND seems to not be needed. I have digital voltage set to same as supply, so yes 3.3V. I tried bypassing the voltage regulator and it did wonders for the baseline energy consumption!
reboot_not_working
I am able to reboot (see image). However I am getting no feedback on any at-commands. I tried just AT as you suggested, and no feedback.
When rebooting the last line I get is +UFOTAS: 0,1, and not OK.

The problem should not be with the EE-NBIOT-01 as I was able to follow the “Interactive terminal” tutorial without any issue with a TTL to USB cable.

The only thing I do to setup the UART log on the OTII is enabling it in project settings and choosing the baudrate of 9600. Does it require more setup somehow?


#4

No, it shouldn’t.


#5

Does it require a premium license?


#6

Is there a way to configure the UART to be in line mode instead of raw mode?


#7

My understanding of the premium license is that it allows for battery simulation. It should not affect the UART handling.


#8

It probably should not be. However I know that scripting is a premium feature, so it is not that far of a stretch. @chrfle, would you happen to know?


#9

Hi,

No, premium is not needed for this.
The settings possible is the baud rate and the display options shown below.
image

Best regards,
Björn