Cannot log in and use license in Otii 3.2.2

Was using 3.1.0, signed in and using our license to operate Otii Ace and Otii Arc boxes. In our old setup we used the TCP server without the UI via ‘otiicli.exe --server --username xxx --password yyy’ but could not find an equivalent in otii 3 software.

I did find a otiiserver.exe but behavior was not as expected. Hoped to fix it by updating to Otii software 3.2.2. I downloaded the installer and executed the installer without issues. After clicking on the Otii shortcut in the start menu the application did not remember my user registration. When I try to re-enter my user name and password in the UI I get an error: “unsable to get local issuer certificate”.

I am working on a company managed PC so I don’t have a lot of freedom to play around with proxy settings etc. It worked before (3.1.0) but now (3.2.2) it’s broken. I am downgrading back to 3.1.0 now but hoping to find a solution… eventually for running the TCP server without having a UI, for now to use the latest greatest software including registration of my account/license.


In 3.1 there was a semi-automatic proxy configuration that sometimes worked, but more often did’t work. In 3.2 you need to explicitly configure the proxy in Otii 3. You find the settings in the preferences.

When it comes to the CLI, Otii 3 does not work as Otii 2, and we have updated the documentation with information on how to move from otiicli to otii_server:

Best regards,

Thanks Joakim, that was very helpful. This seems to solve my issues.

Note to self: you need to match latest software with latest documentation;

  1. otii_server from version 3.1 had parameters to use username/password. Now you have to do user management via python code as explained in documentation referenced above.
  2. The reason otii server was not working was indeed an error in proxy configuration. In the dump shown when starting the server from powershell cli (I used to start the server from python code, missing the dump) you could see the same error. You can configure proxy via --config as explained in referenced link above.

Looking forward to a future release where you can run the server as a windows service.