Firmware upgrade to 1.0.9 broke the device


#1

Hello there!

I recently installed 2.1 version of PC (Windows) software and tried to upgrade device firmware to version 1.0.9.
During the firmware upgrade, the info log with “bossac…” command showed and stayed like this for over 10 minutes.
When my patience runs out I tried to do firmware upgrade again with no luck…
Now, the Otii software does not see my device. When I try to upgrade firmware I get:

Upgrading Arc connected to: "COM10"
\"C:/......./bossac\" --port COM10 -i -e .... Arc_1.0.9.bin
The firmware upgrade process failed with status code: 1
No devices suitable for upgrade connected

When I plug/unplug USB from Otii device I get:

Device in firmware upgrade mode removed:
Device in firmware upgrade mode added: "COM10"

When I run bossac command manually I get:

> bossac -p COM10 -i -e -w -v -b -R -U true -u Arc_1.0.9.bin
No device found on COM10

Any help would be appreciated.


#2

Hello

Not quite sure what happened there. Could you please try the following:

  1. Unplug USB.
  2. While pressing the reset button in the small hole on the back, insert USB again
  3. Try firmware upgrade again.

If this does not help, I would advise you to reboot your computer. We’ve had a previous instance where a firmware upgrade scenario got sorted after rebooting Windows.

Let us know if it helps!


#3

Thanks for the quick reply.
Pressing the reset button on the device while connecting USB didn’t help.
Rebooting Windows did help, partially.
Now, I’ve repeated what happened at the beginning, the complete history is:

Starting "2.1.0"
Device in firmware upgrade mode added: "COM10"
Otii already latest version: 2.1.0
Warning: file:///C:/......./otii/QtQuick/Controls/Private/BasicTableView.qml:615:17: QML QQuickItem*: Binding loop detected for property "width"
Upgrading Arc connected to: "COM10"
"\"C:/...../otii/bossac\" --port COM 10 -i -e -w -v -b -R -U true -u \"C:/.../Arc_1.0.9.bin\""

How long does it take?..
I’m writing this about 35 minutes later and nothing changed.
In the process manager, I can see that the bossac.exe is on.
Process explorer saying that bossac.exe does not use CPU and I/O at all while otii.exe does ~2% of CPU and 5-16KB of I/O.

In the process monitor, I can see that otii.exe all the time (every ~500ms) is checking some registry values + creating/querying oem106.* files in my windows/** directory…

If nothing comes to your mind that I can try I will try again with windows defender disabled, or with Otti started in admin mode.


#4

I’ve fixed it with the following steps (workaround):

  1. Run Ubuntu 18.04 on VirtualBox
  2. Install Otii on Ubuntu
  3. Enabe USB\AVR Samba on Virtualbox
  4. Run sudo otii
  5. Perform firmware update
  6. At first it was same error as on Windows:

    The firmware upgrade process failed with status code: 1
    No devices suitable for upgrade connected
  7. Turn off usb cable from Arc
  8. Turn on Arc with reset button ON
  9. Update firmware again: success!
  10. Turn off virtual machine.
  11. Arc works on Windows again.

…Not sure what was the reson of this malfunction.
Will check again with next release update;)