Minimum Baudrate Setting


#1

Hello,

I am trying to connect my EUT with Otii over UART connection and Otii is powered by USB connection. As I have checked baud rate setting in UART tab but not found support of 4800 baudrate.

Please let me know Otii having support of 4800 baudrate.

Regards,
Ritul


#2

Hi,

The baud rate setting is editable, so you can choose something else than the predefined values.
So 4800 is supported by Otii.

Best regards,
Björn


#3

Hi Bjorn,

Thanks for quick reply.

I didn’t found editable option in baud setting. Please describe where is option,

Regards,
Ritul


#4

Hi Ritul,

Just edit the baud rate box with wanted value and press enter.
If you leave the Logs tab and go back to it, you will see that your edited value is still there.

Best regards,
Björn


#5

Hi Bjron,

I have updated Otii firmware version 2.5.4. Problem solved. Now there is option of editable baud rate setting.
Now I want to send command to EUT using Otti GUI, check reply & measure current on run time. So, I made setup having EUT connection (Tx,Rx,GND) to Otii (Rx,Tx,DGND), start recording and powered up EUT by Otii,select 4800 baud rate. Also, used premium Otii version. When i was sent any command to EUT by Otti GUI, No reply is there.

image

Regards,
Ritul


#6

Hi Ritul,

Make sure that you have the latest FW since we have had a few bugfixes regarding UART.
Secondly, loop your Otii TX to Otii RX and confirm that you are sending data.
Make sure that you always have a recording running to send data.

Best regards,
Björn


#7

Hi Bjron,

I have used latest firmware and follow connection EUT Tx to Otii Rx ; EUT Rx to Otii Tx and EUT GND to Otii DGND. Here not using any external converter for UART.
While sending command , recording is running. I have verified that EUT UART is working properly. Still Problem is facing

image
Regards,
Ritul